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Leveling Up
Earn CE certificates
via many of these free
and low-cost webinars,
courses, and seminars.
See altshift.education/
events, edWeb.net,
EduPaths.org, Kent
County ISDs PD
Hub, CECatalog, and
ADDitudemag.com for
additional instruction.
•

Executive Function
for Today’s Student
and Tomorrow’s
Leader, Thurs, April
5, at 5 p.m. EDT on
edWeb.net.

•

The Power of Block
Play, Mon., April 9 at 3
Cont. on page 2

Managing online assignments
with Google Classroom
These days there’s a wealth of
learning software and games you
can assign to your students. But
keeping track of student progress
on each, not to mention dealing
with all the different student logins
and passwords, can be a timeconsuming headache.
Google Classroom simplifies
things, and best of all, it’s free.
For students, it’s a site into
Please see Google Classroom on page 7

Chrome browser extensions to
keep you alert!

by Kindy Segovia
OTR, Assistive Technology Supervisor, Kent ISD
@kindysegovia
The rapid expansion of technology use in schools
has included broad use of the popular Chrome
web browser. From schools that have adopted
Chromebooks as their student devices of choice, and
those using Google as their digital platform, Chrome
plays a central role in many classrooms.
A natural, and often invaluable component of the
Kindy Segovia
Chrome browser, is the Chrome Web Store, a portal
for browser extensions and apps that can support many areas of student
learning. What is a Chrome extension? It’s a small software program that
customizes the browser experience with added features and functionality.
Please see Take a break on page 8
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Leveling Up, continued from page 1

About Special Ed Tech / Subscriptions

p.m. EST on edWeb.net.
•

A Fresh Look Test-Prep Tools, Tues., March 6 at
4 p.m. EDT on edWeb.net.

•

Innovative Leaders Redesign Schools for the
Future of Education and Work, Tues., April 10
at 4 p.m. EDT on edWeb.net.

•

College and Career Ready! Motivate and
Empower Struggling Readers in High School,
Wed., April 11, at 3 p.m. EDT on edWeb.net.

•

Three Questions Every Teacher Should Ask
About Edtech, Thurs., April 12, at 4 p.m. EDT on
edWeb.net.

•

Minimizing Summer Slide Through a Collective
Impact Model, Mon., April 16 at 4 p.m. EDT on
edWeb.net.

Special Ed Tech, specialedtech.net, is published
monthly from September through May by
the director of Aspiring Games Foundation,
aspiringgames.org.
To subscribe, go to specialedtech.net, scroll
to the subscription box on the bottom of the
page, insert your e-mail address, and click the
“Subscribe” button.
We welcome your questions and article
suggestions. Direct all queries and subscription
issues to editor Becky Palmer-Scott at
SpecialEdTechEditor@gmail.com.

•

Learner Positioning Systems: Navigating
Learner Variability, Wed., April 25, at 4 p.m. EDT
on edWeb.net.

•

Repurposing Consumer Technology to
Enhance Communication & Learning for
Individuals with Autism, Thurs, April 26 at 3 p.m.
EDT on edWeb.net.

•

The Importance of Keyboarding, Thurs., April
26, at 5 p.m. EDT on edWeb.net.

•

Amplifying Student Voice with Technology,
Tues., April 17, at 4 p.m. EDT on edWeb.net.

•

Inclusion Is More Than “Just Being In”, Wed.,
April 18, at 3 p.m. EDT on edWeb.net.

•

Leading with Data: One District’s Journey to
Student Success, Thurs., April 19, at 3 p.m. EDT
on edWeb.net.

•

End Peer Cruelty, Build Empathy: Create Safe,
Caring, Inclusive Learning Climates, Mon., April
23, at 2 p.m. EDT on edWeb.net.

•

Funding Social Emotional Learning: Where’s
the Money?, Mon., April 30, at 4 p.m. EDT on
edWeb.net.

•

How Diet, Sleep, Exercise & Behavioral
Interventions Can Reduce ADHD Symptoms
in Children, Tues., April 24, at 1 p.m. EDT on
ADDitudemag.com.

•

Effective Discipline Policies for Young
Children: Supporting Social-Emotional
Competence, Tues., May 1, at 3 p.m. EDT on
edWeb.net.

•

Classroom Management Mistakes That
Undermine Your Authority, Tues., April 24, at 5
p.m. EDT on edWeb.net.

•

•

Unlocking Opportunities Through Family
Literacy, Wed., April 25 at 3 p.m. EDT, on edWeb.
net.

Best Digital Reading Practices for Early
Literacy: Strategies for Teaching PreK-Grade
3 Students, Tues., May 1, at 4 p.m. EDT on
edWeb.net.

•

Creating a Classroom of Active Nonfiction
Reading Detectives, Thurs., May 3, at 4 p.m.
EDT on edWeb.net.

Link to page 1
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Google tools for ESL/ELL
If you have a student in the classroom who is
learning to speak and read English, there are several
tools and extensions/add-ons available in Google
Chrome that can help.

ESL/ELL Aids lists
tools to help students
who are learning
English

To add extensions in Chrome, click on the Apps grid
at the left side of the Chrome browser, then click on Web
Store to search for and add extensions.

Google Docs Tools: Translate & Voice Typing
Google Docs Translate and Voice Typing are built right into Google Docs so
you don’t need to add an extension to use them.
Google Translate can translate a document in Google Docs from one
language to another, allowing a non-English speaking student to read a
document you have written in English, and allowing you to read in English what
was created in another language. To use the tool, from the Google Docs menu,
select Tools > Translate document..., then select the language you want the
document translated into. Google offers more than 100 choices so it’s likely that
your student’s language will be included.
If your student does not know how to read, use the Read&Write extension
described below to help.
If you student cannot write, he or she can still communicate with you,
because Google Docs allows voice typing and can also recognize non-English.
To select a language, from the menu bar select File > Language and select the
desired language. Then have the student select Tools > Voice Typing and click
on the microphone to begin speech-to-text input, and again to stop. Then use the
translate tool to put the document into English.

Read&Write

Read&Write extension

Read&Write is a text-to-speech extension which can read aloud PDFs,
websites, and Google documents. The user can start and stop the voice. If
desired, the user can select a section of text to be read. The program highlights
each word as it is voiced.
Read&Write’s free version can read in a wide variety of non-English accents
including French, Portugese, Spanish, and Dutch. Click on the purple arrow at
the right and then click Options to find out more.
Read&Write also includes a Practice Reading Aloud feature which lets
students record their reading and email it to teachers.
The paid version of Read&Write includes a dictionary, a picture dictionary,
and a translator. See this link for paid features.
Please see ESL/ELL tools on next page
Link to page 1
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ESL/ELL tools, continued from previous page

Google Translate for web pages
Many people are familiar with Google’s ability to translate foreign web pages
into English. Google can also translate an English page into another language.
To enable this, install the Google Translate extension on the student’s device.

Google Translate extension

To select a language, click on the Google Translate icon in the Chrome menu
bar, then click on Extension Options. In the My primary language drop-down
menu, select the student’s language, then click Save.
To translate a web page, click on the Google Translate extension, then click
TRANSLATE THIS PAGE. You can also change the translation on the fly by
clicking on the language drop-down menu and selecting a different language.

Google Dictionary

Google Dictionary extension

The Google Dictionary add-on allows students to select a word on a web
page and see what it means. They can also type words in the Define field to see
definitions. Similar to Google Translate, the Extension Options feature allows
users to pick a language to see the results.
For ideas on how to use these tools in the classroom, see the EdSurge
article, “Seven Ways to Use Google Docs to Support Biligual Student Writers.”

Link to page 1
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Google educator resources
ShakeUpLearning.com free resources

ShakeUpLearning.com is a terrific
resource for teachers interested in using
Google educational products. Written
by Kasey Bell, a digital learning coach
and consultant, the site contains video
instructions on how to get started with
Google Classroom, a host of resources
and tips such as a database of Chrome apps and extensions, coding resources,
and more. The site also offers paid online courses. Check out the search bar on
the site to find exactly what you want.

Google
Teacher Tribe

Google Teacher Tribe free tips & podcasts

The Electric
Educator

The Electric Educator: free ideas & webinar
April 26

Google Teacher Tribe offers a large variety of podcasts on how to use Google
in the classroom. Topics include Google Sheets Add-Ons; Doing more with
Google Forms; Quizzes, Quizzes. Google Forms Quizzes; Google Classroom
Time-Savers, and many more...50 total at the time of publication. Of special note
is Google in Special Education | Interview with Carrie Baughcum, which talks
about how Carrie integrates Google, creative thinking, and gamification into her
classroom.

When Google put on a educational session for educators in Lansing, Michigan,
they hired John Sowash to discuss how to use Google Classroom. John is a
Google Apps EDU Certified Teacher, and author of The Chromebook Classroom,
the first full-length book on the use of Chromebooks in the K-12 classroom.
John’s blog is called The Electric Educator, which offers many ideas. He is also
offering a free webinar on becoming a Google Certified Educator. RSVP here.

Link to page 1
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Computer programming for girls
If you’re looking to interest girls in computer programming, check out Made w/
Code, Google’s venture into coding for kids. The site provides tutorials on coding
involving subjects of interest to girls, such as Wonder Woman, Inside Out,
equality, avatar and clothing design, and more. The site also features female role
models in the coding world, local resources, and tips on hosting a coding party,

Link to page 1
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Boys continued from page 1

Unfortunately,
the classroom
environment of sitting
still and listening
is not something
that boys generally
excel at. And actions
which boys take to
build themselves
up – throwing things,
running, jumping,
taking risks -- often
get them in trouble.

which they can log in once and access many if not all of their assignments. It
even allows students to collaborate with each other. For teachers, it’s a one-stop
place to assign and monitor student progress on online learning programs and
games.
The best way to get started with Google Classroom is to sign up for G
Suite for Education, available free for schools and nonprofits, which provides
productivity tools, security, and tips for hardware acquisition. Although Google
Classroom can work without it, you must use G Suite for Education if users will
not be signing in with gmail accounts.
Of course, Google Classroom works with all the Google products such as
Google Docs and Google Slides (presentation software similar to PowerPoint).
It also works with a wide variety of non-Google software, such as BrainPOP,
Classcraft, DuoLingo, GeoGebra, Newsela, PBS
Learning Media, and Quizlet.
For more information about the many apps that
work with Google Classroom, see 50 Awesome
Apps that Integrate with Google Classroom on
shakeuplearning.com.
The site includes a helpful free mini-course,
Getting Started with Google Classroom, which includes
instructional videos and additional resources.
Shakeuplearning.com also offers tips on creating differentiated assignments
in Google Classroom and 350+ Google Classrom Tips and Resources.

Link to page 1
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Take a break, continued from page 1
Several extensions provide easy access to fun and effective brain breaks
and other tools that assist with focus and independence. See “The importance
of taking a break” by Psych4Schools for more information about the educational
effect of breaks.
To add extensions in Chrome, click on the Apps grid at the left side of the
Chrome browser, then click on Web Store to search for and add extensions. A
few go-to extensions to try:
Move It: Set the notification interval and the screen will present you with
random exercise, movement or brain breaks.
Save My Eyes: Regularly reminds you to take breaks so you can relieve
tension from your eyes, move your body, or just relax.
Move It

Take a Break: Provides reminders to take a break from your computer work
or web surfing.
Break Timer: Break Timer allows you to set up customizable breaks and will
remind you to take them.
Posture Minder: Set how often you’d like to see a PostureMinder, then sit
back and let it do its work reminding you with fun messages.

Break Timer

Mindful Break: Gives you a mindfulness tip and guides you through a short
breathing exercise. Set reminders to help you remember.
One Click Timer: A nice visual timer that functions as both a countdown or
counting up timer.

One Click Timer

Use these extensions quickly and easily from your browser’s menu bar.
They’re great for whole group and class instruction or for individual student use
in a 1:1 environment. They’re even great for you, the educator, during those long
moments or hours in front of your computer screen!
Kindy Segovia, OTR, is currently the Assistive Technology Coordinator at
Kent Intermediate School District, Grand Rapids, Mich. She has worked as
an occupational therapist in both schools and pediatric rehabilitation for over
25 years. She has provided educational training for teachers, parents and
administrators over the past 15 years with a focus on adapting curriculum,
classroom accommodations, and integrating technology into instruction. She is
also an adjunct professor at Grand Valley State University. Find out more from
Kindy at kindysegovia.com.
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